Topic: Fireface UC pitch problem

Hello everyone,
Ive just started using a Fireface UC which, by the way, is fantastic.
The problem Im having is with pitch I think.
Let me explain.
When I installed the driver and got everything set up the first thing I did was play one of my favorite tracks using windows media player to see how it sounded.
It sounded great but the song had changed pitch. It was way to high and fast. I tried with VLC player and that was the same.
So, I used the pitch control in the settings dialogue and tweaked it so that the track sounded normal.
I thought that was the end of the problem.
Now, when I record with my SONAR program everything sounds OK until I render a track to mp3.
When I do this the mp3 changes pitch. If I record a song in A, by the time its rendered to mp3 the key is B and its much faster.
Can anyone out there help me to get a stable "one pitch for everything"?
Thanks in advance.
Eugine

Re: Fireface UC pitch problem

If you record with a reduced sample rate ("lower pitch"), a resulting file in mp3 (rendered to e.g. 44k) will sound too high. Using the pitch control to fix the problem with your favourite song can not be a solution.

Please reset the pitch to normal and test your original file again. How much is the pitch difference you perceive? Can you compare with e.g. playback from a CD player?
If as you say it is about semitone or a bit more, you seem to be playing 44k material at 48k somehow. Which sample rate dies the UC settings dialog show? Is this a Mac or PC?

Regards
Daniel Fuchs
RME

Re: Fireface UC pitch problem

Daniel,
Thanks for your reply.
The sample rate on the settings dialogue in the clock mode is 45542hz. I am using a PC with windows 7.
If I play the rendered mp3 on my PC it sounds O.K. But when I play it on other computers or CD players it is a semitone higher.
How do I reset the pitch back to normal. I changed the pitch by ear. I dont know what the original settings were.
Mike

Re: Fireface UC pitch problem

Simply reset the pitch slider in the settings dialog to 0, so it shows straight 48 or 44.1 kHz.
Are your initial observations based on one single song, i.e. one file only? Or what else have you compared?


Regards
Daniel Fuchs
RME

Re: Fireface UC pitch problem

Yeah, I set the pitch to zero and now everything is playing O.K. I have no idea why the pitch went so high when I installed the driver. Anyway, Ive just played a song in SONAR and it sounded good, then I rendered it to mp3 and played it on another computer. That also sounded good. No pitch change. Then I played a few songs by the Clash on my PC. No problems, everything is good.
Thank you for your time and advice.
Youve been a big help.

6 (edited by ZwiebackMeister 2014-04-12 09:16:13)

Re: Fireface UC pitch problem

Hi there,

I think I have the same "problem" with my Fireface UC and Windows 7, 64 bit. It happens from time to time that when you restart your PC, the pitch is way off, even if the slider is set properly to 0! By a pitch modulation with e.g. audacity one can find out the real amount of modulation, most of the times when this happens its +/- 10%, +/- 50%, sometimes its even -150%!! If you quickly set a new pich on the slider in the control of the Fireface USB Settings, you can easily reset it to the normal 0 pitch.

You can also trigger this event by klicking hundreds of times on the slider at a different position then where it currently is. Then it sometimes will also jump to these extreme pitch values.

For me the question is how can I directly set pitch values below +/- 5 %?

Can you update the driver so that one can choose up to +/- 150% ?

Because then I could do some crazy ass sound effects directly with the RME via Hardware, which would be superb!! Otherwise I use a software to do it which sounds crappy of course.

Kind regards,
Martin

7

Re: Fireface UC pitch problem

IMHO this problem (pitch not zero) has been fixed long ago, so the question is which driver version has been installed.

Regards
Matthias Carstens
RME

Re: Fireface UC pitch problem

Hi MC,

Thank you for your fast response!
Yes, I indeed use an very old driver, I guess from 2010 or so.

But is there a posibility to manipulate the pitch further with a newer driver?

Greetings,
Martin

9

Re: Fireface UC pitch problem

No, because such big changes cause all kinds of ill side effects. Your player software will simply freak out - or Windows. Under USB even the data stream handling will not be able to follow without drop outs or distortion.

Regards
Matthias Carstens
RME

Re: Fireface UC pitch problem

sad

Ok, thanks again.

Re: Fireface UC pitch problem

Hi,

I am having a similar problem as was originally posted in this thread with incorrect pitch. I am running Pro Tools 10.3.8 on windows 7 with the Fireface UC, all brand new gear bought this spring. My problems started with the occasional session playing pitched up a whole tone and faster that recorded, but it seemed tp settle out. Then I mixed a session for a client which seemed fine until I bounced it and played the resulting file which was pitched up. I thought it was a bug in the DAW so I did a complete clean reinstall. No luck. Then I did the same with the Fireface UC, installed the latest driver again and now EVERYTHING is pitched up, all my sessions sound this way. Nothing obvious like pitch set up or anything else I can discover. Please help.

Thank you.

12

Re: Fireface UC pitch problem

Please post a screenshot of the UC Settings dialog.

Regards
Matthias Carstens
RME

Re: Fireface UC pitch problem

Hi there,

After a considerable effort I have discovered the issue, it seems the UC, which is set to internal clock, is not following the rates of my sessions. For example I open a session which is 48/24 and then switch to another session at 44.1/16 the internal clock is stuck at 48 and I have to manually change the setting by closing Pro Tools, making the change and reopening the session. This is a new issue as there was previously no issue with the UC following the session rates. I also discovered that sometimes the setting would state the correct rate yet the session would play pitched, if I again manually change it to a different rate and then back to the correct one it works. Here is the screen shot of the dialogue box without PT open.


http://imgur.com/KbtHhpX


I made my deadline by finding the workaround but I am hoping to find a permanent fix.

Thanks so much for your time.

14

Re: Fireface UC pitch problem

Well, that's what I expected - outdated driver...this is version 1.043 of February, if at all. Current one is  (skip 1.046, 1.048, 1.050) 1.053. It allows to set the number of WDM devices to 0 (or 1) which might help on your system to make the sample rate follow more properly (explained in the driver's readme for version 1.046).

Otherwise this is a bug in PT as our units have zero problem to follow external ASIO sample rate requests when in internal clock mode.

Regards
Matthias Carstens
RME

15 (edited by becomingsound 2014-07-30 04:12:33)

Re: Fireface UC pitch problem

Yes this was the issue, thanks so much for having me look more closely at the driver version, not sure how I messed it up. I think I downloaded the legacy driver inadvertently instead of updating at some point during my rush to find the problem. I greatly appreciate your timely reply and my apologies for posting before checking everything. On another note I am very impressed with the response time and am happy to be using RME gear which I intend on expanding in the future. Thanks again MC!

All the best,
Shawn