Topic: Digicheck 5.75 crashes everytime I start the program

Hey guys,

I've tried to re-install Digicheck a couple of times, making sure that I didn't have anything with the name "digicheck" in my windows 7 registry, or had any folders left on my win7 partition (looking in my profile, program files, program files (x86)). But no matter what I do, it crashes on each start.

Well, after I deleted everything I could find with the name "digicheck", I now get a dialog asking me to set a temp folder. But after selecting this folder, Digicheck crashes.

My sound I/O card is a RME HDSP 9652 PCI card, and I use the latest 4.04 driver.

Hmm.. I just wanted to ask you guys, if some of you were having start crash problems with Digicheck, or it's a problem here on my setup? smile

RME Raydat, Asus Z370-A prime, i7 8700, Noctua D15s cooler, Corsair RM850x, Crucial 32GB DDR4 ram


Re: Digicheck 5.75 crashes everytime I start the program

Here are some ideas on how to pin down the problem:

- What and where is the temporary directory that you assign? You might try to use a place on a different drive/partition.

- Where is DC currently installed? You can copy the install directory to as different drive/partition and start digicheck.exe from there to see if it makes any difference.

- To rule out the HDSP9652: go to Device Manager and deactivate it. No need to uninstall or remove it physically. Then start DC and see if it still crashes.

Matthias Carstens

3 (edited by SLL 2015-01-02 19:53:25)

Re: Digicheck 5.75 crashes everytime I start the program

Hey Matthias, sorry for the late reply.

I tried to disable the device driver, which sort of solved the problem. It's seems like there is some kind of conflict between the new 4.04 driver, and the Digicheck program.

What happen is:

1. I disabled the HDSP9652 device driver in win7's device list.

2. now Digicheck could start (+ selecting a new global temp folder, the first time I start Digicheck), but with an error saying "opening audio device - error number 4".

3. If I enable the HDSP9652 device driver, I can now start Digicheck, but gets the "opening audio device - error number 4", each time I start Digicheck. If I disable the driver, Digicheck starts without the error.

So I guess there is some kind if driver problem between digicheck and the HDSP9652 device driver. Could be because of the new v4.xx driver, as I haven't had this problem before with the v3.xx driver.

Hmm... I'm thinking if it's a setting problem on the HDSP driver, that causes Digicheck to fail? Just don't know what I need to change in this case smile

If I choose to set the input device to ADAT1 in Digicheck,  Digicheck crashes... but does remember the setting the next time I start Digicheck.

All the best, happy new year,


I've made a gif recording of what happens, when the HDSP driver is enabled, and I start digicheck: … driver.gif

After that, Digicheck crashes.

When I disable the HDSP driver, Digicheck does start without any errors. But than I can't select the ADAT input, as the driver is disabled. And I can't playback anything, as there is no device driver. But the previous set ADAT input is remembered in the input selection dialog.

Now I'm trying to install the HDSP 4.04 driver again, see if this help anything. Maybe if I can find v4.03, I'll try to install that that, if the 4.04 inst. fail.



Okay, after re-installation of Digicheck I got it to work. The whole difference after re-installation was, that I now was able to "save" the input ADAT selection without the Digicheck crash. And after that, I could start digicheck and the input ADAT settings was remembered correctly.

So now I'm a happy man, everything seems to be working now smile Not sure why I suddenly had the problems, as Digicheck has never before caused any problems.

But thanks Mattias, for replying to this topic, and helping out. It was actually you, that said I should try and disable the HDSP driver, that eventually after some time fiddling with the problem here, solved it.


RME Raydat, Asus Z370-A prime, i7 8700, Noctua D15s cooler, Corsair RM850x, Crucial 32GB DDR4 ram