1 (edited by talino 2016-02-25 01:45:35)

Topic: Cubase trashing the Fireface UC

Hello,

Been using Cubase for years with the same audio interface on different Macs, just came across what is probably the strangest show-stopping bug that I ever came across.

Just moved my master machine to a new iMac. Installed drivers and software like I have been doing for years (I always do clean installs of OSX once a year). Using same Cubase version and same templates. Here's what happens.

1. Turn on the iMac.
2. Play an audio file in Quicktime or VLC, everything's fine.
3. Launch Kontakt or Reaktor, load a patch, no problems.
4. Launch Cubase, load an empty project, add an instrument track, play something, still cool.
5. Close the project. Load one of my regular templates or an old project (by old I mean from two days ago).
6. Meters are moving, Stereo Output too, sent properly to the analog outputs of the audio interface, but nothing is heard. The meters on the audio interface's driver & mixing software (TotalMix) don't register a single pixel. Totally dark.
7. Quit Cubase.
8. Try to play an audio file in Quicktime or VLC. Nothing. Complete silence.
9. Launch Kontakt and play something. Kontakt meters are moving, audio interface is dead.
10. In the interface's driver window, change sample rate to any value. Audio from the file plays for a second and then stops, like a glitch.
11. Turn off the audio interface while the computer is still running. Turn it back on.
12. Audio plays normally.
13. Restart, rinse, repeat. I've done this four times.

I have to get back to work but I haven't the slightest idea on how this might be solved. I repeat that I've installed and configured OS X with the RME Fireface at least ten times in the last years, something like this has never happened. I would have concluded that it's an iMac USB issue if software other than Cubase wasn't behaving normally. My template is doing something drastic to my audio interface and I have no idea what it could be.

Thank you for any ideas.

2 (edited by ramses 2016-02-25 08:03:49)

Re: Cubase trashing the Fireface UC

You forgot to mention any relevant information in terms of whats the difference between the old and new installation.

What Mac did you have before, whats your new Mac HW ?
What OS X version did you use on the old machine, what on the new machine ?
What RME driver version did you use on old machine, what on the new HW ?
What Cubase version did you use on old machine, what on the new HW ?

Is the old Mac still available in the same status as it was when all was running fine for you ?

If yes, then I would do 2 things
a- validate, that the UC is still running fine on the old HW with the same USB cable
b- try to find out the difference between new and old Mac in regards to
    - OS X version
    - RME driver
    - Cubase version

You could also try to connect the UC to different USB ports if available to see whether something changes if you use another port.

BR Ramses
UFX+, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1650v4, Win10Pro22H2, Cub12Pro

3 (edited by talino 2016-02-25 11:09:00)

Re: Cubase trashing the Fireface UC

Sorry, my config:

MASTER: Cubase Pro 8.0.35, iMac 27 2015 i7 4.0 (17,1) 24gb RAM, OS X El Capitan 10.11.3, RME Fireface UC. SLAVE: Mac Pro 2009 Quad 2.66, 28gb RAM, Vienna Ensemble Pro 5.4.

Just checked and RME works fine on the Mac Pro, with the same USB cable. Only difference is that Mac Pro is running El Capitan 10.11.2.

Same Cubase version on both (8.0.35), same RME driver on both (firmware v123, driver v2.10). Changing the USB port doesn't help. I also tried changing sample rates and buffer size from within Cubase, same result.

A simpler test I tried:

1. Restart iMac.
2. Launch Cubase.
3. Switch ASIO to built-in Core Audio.
4. Play something, works fine (with huge latency obviously).
5. Switch ASIO to RME Fireface.
6. Play something, hear nothing. Meters in Cubase move, meters in RME don't.
7. Rme is dead until off/on routine.

Please help me figure this out as I am having a big downtime here.

Re: Cubase trashing the Fireface UC

If I remember right I read about issues with El Capitan in this forum.

Could it perhaps be a similar problem like this ?
https://www.forum.rme-audio.de/viewtopic.php?id=23151

BR Ramses
UFX+, 12Mic, XTC, ADI-2 Pro FS R BE, RayDAT, X10SRi-F, E5-1650v4, Win10Pro22H2, Cub12Pro

5 (edited by talino 2016-02-28 16:15:16)

Re: Cubase trashing the Fireface UC

Sorry for the delayed response, I didn't get an email notification. This looks like a similar problem, yes, but both proposed solutions didn't work for me. Any news from RME on the subject? I've been going crazy with this for the last 3 days since getting my iMac 27. RME plugged into any of the USB3 ports, audio trashed completely when I launch Cubase. The only way to get it back is power cycle the unit while Cubase is running.

EDIT: This has become a regular and repeatable issue. Audio disappears whenever I close and open projects, power cycling while Cubase is active always solves the issue. This is very annoying.

Another thing which might help in fixing this: I have a Network Session set up up in Audio MIDI Setup which transmits MTC over LAN to another Mac for video playback. This is unrelated to the RME interface, of course (I'm using its MIDI input ports for my keyboard only). However, when I change Cubase projects, not only the RME audio disappears but the MIDI sync is completely off, playback stutters heavily on the other machine.

Weirdly enough, power cycling the RME interface solves this, too.

It seems to me that there is a low level problem with the way the RME Fireface UC speaks to the iMac's USB3 interface. Support, please?