1 (edited by amzavareei 2017-10-23 23:54:23)

Topic: Pro Tools halts with RME RayDAT on any buffer size other than 1024

Hello,

I've got an RME RayDAT HDSPe PCIe card connected via lightpipe to three Steinberg Nuendo branded RME 8x8 converters. The card is in a pci lightning chassis connected to a recent model 6-core Mac Pro. It works perfectly only if the buffer size is 1024, even with just one audio track with no inserts or sends. If I set it to 512 I get an instant -6101 error and playback halt. This makes monitoring difficult unless I do special routing in Totalmix and monitor through a different headphone amp I have set up.

I've messed around with all the playback engine and IO settings, as well s the RME Raydat HDSPe settings. The converters are set to input sync, and the Raydat is set as the master clock. I've tried turning off everything like the ethernet, spotlight, sharing, etc... I even changed my video card driver and removed my Black Magic video card. I changed from the raydat playback device to an aggregate including it. I put all plugins in an unused folder. I've done just about anything a few hours of googling that error recommended.

I also have 2 quad UAD-2 cards installed. I even tried removing them. I'm thinking of moving the RME card to another slot.

Again, everything is fine just with a 1024 buffer size, but that's it.

This is Pro Tools 10.3.10 on OS X 10.9.5.

It wasn't always like this, and I don't know what has changed. But even when it was better, I could not go down below 512 reliably when tracking.

Any help would be much appreciated!

2

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

> The card is in a pci lightning chassis

Something like that doesn't exist. Thunderbolt 2 to PCI? What brand and model? What is the firmware version of the RayDAT card and what driver version?

Regards
Matthias Carstens
RME

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

Thanks for the reply.

Calling "Thunderbolt" "Lightning" is something I've done since they came out. I can't get out of the habit!

Sonnet Echo Express III-R

Mac Driver is 4.10

Firmware is 13.

So it should be up to date.

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

I even just swapped pcie slots with the same result.

5

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

Please ask the Sonnet guys, they are great and might have another idea.

Regards
Matthias Carstens
RME

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

I rolled back to the 4.06 driver I had on my hard drive and I don't have the problem anymore. So I guess maybe you guys can figure out the problem with the 4.10 driver, and should at least supply more old drivers online for people like me. A change log would be nice too. Is one available?

Thanks.

7

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

There have been zero changes from version 4.06 to 4.10 in the kernel driver. The only change is the consecutively updated TotalMix FX. The readme is where one expects it - in the driver archive.

To test this further you should reinstall 4.10, check the error is back, then completely quit TotalMix FX, restart ProTools, check for the error again. It might be that this issue is some weired interaction with MIDI ports and other stuff (Avid plugin) again. We have checked the RayDAT with a Thundertbolt box today and did not find any problem.

Regards
Matthias Carstens
RME

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

So yeah, it works with 4.10 again now. First I installed 2.72, that worked, then installed 4.06, and that worked, and lastly re-installed 4.10, and that works. Sort of strange, and it was at least a full days troubleshooting to fix. Still not sure what the problem was, but it works now! Faith: restored.

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

Hello again,

I updated the HDSPe RayDAT firmware from 13 to 16 and now I get stuttering in OS X and -6101 errors in Pro Tools again. An MP3 or WAV starts out fine for a few seconds, then it starts stuttering more and more as it plays. I tried rolling back to several different versions(2.67, 2.72, 4.06, 4.11) of the driver again, with no luck. This was all running fine for about a year until the firmware update.

Any suggestions?

Thanks.

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

I even just rolled back to firmware version 12, and still the same issue. What's the best way to totally uninstall all RME software and start from scratch?

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

I went and deleted every single RME or HDSPe file I could find, repaired permissions, verified the disk, rebooted and reinstalled the driver. I still get the same error. Audio files play from VLC fine for a few seconds, then they start to stutter. Pro Tools won't even play for a split second before crapping out. I've tried every setting combination I could think of in the HDSPe settings and my RME ADi-8 Pro to no avail.

This is on Mavericks, and all was running great for a year until I updated the firmware from 13 to 16.

What else can I do?

Thanks.

12

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

It should be quite obvious now that the firmware update did NOT trigger this behaviour, but any other update done in that time. Driver, software or OS ones.

OR

any of the audio-related hardware and cabling is defective.

One thing I would try: remove the RayDAT and clean its golden PCIe contacts carefully with a rubber eraser.

Regards
Matthias Carstens
RME

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

I'm not sure why that would be obvious. Literally the only thing that changed was upgrading the firmware. I didn't even update the driver until after this issue popped up. I even booted to a backup drive that had an image of OS X from before the firmware update, and I still get the error. It had driver version 4.06.

This was a working Mavericks/Pro Tools HD 10 system for the majority of 3 years.

The card does seem to work fine in a windows computer I put it in.

Is it possible for me to get Firmware version 13 somewhere? Every possible version of driver, firmware and TotalMix FX  you could provide would be great so I can find a working combo again.

Thank you.

14

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

http://www.rme-audio.de/download/fut_mac_dspe_227.zip

Regards
Matthias Carstens
RME

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

Thanks MC, but I have that version still. It looks like it has firmware 11 according to the readme file. The last version firmware I had working properly was version 13, with driver version 4.06.

16

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

The readme in that zip says 13.

Regards
Matthias Carstens
RME

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

I unzipped it and readme FUT.rf says:

RME  Intelligent Audio Solutions

HDSPe Series (PCI Express)

Flash Update Tool 2.20 for Mac OS X Intel 10.4.8 and up


Important notes:

This program updates the HDSPe firmware to the latest revision:

- HDSPe PCI and ExpressCard Rev. 18

- HDSPe MADI Rev. 25

- HDSPe RayDAT Rev. 11

- HDSPe AIO Rev. 10

- HDSPe MADIface Rev. 11

- HDSPe AES Rev. 7

It requires driver 2.54 or up, or driver 1.71 or up.

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

I see the issue, sort of. Your link says 227, even when I mouse over it in the status bar, but it downloads 220 instead.

19

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

Sorry for that. Works now, please download again.

Regards
Matthias Carstens
RME

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

Thanks MC,

Unfortunately that didn't work. After I loaded version 13, I booted to an untouched backup of my OS from when it worked, and still it has the same problem. I was using VLC an iTunes to test, since it loads faster than Pro tools. The audio starts fine, then after about 10 seconds, it lags and stutters, getting worse and worse.

I have tried many different combinations of firmware and driver with no luck. Is there no way to wipe out all trace of RME software and start from scratch?

I even swapped PCIe slots to the same result.

It seems to run OK in Windows, but I need to run more tests. Regardless, the Mac is my workstation that has many sessions with Mac only virtual instruments I need to get back to soon.

Please let me know if you have any other ideas.

Cheers,

AZ

21 (edited by ramses 2018-11-27 06:54:36)

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

amzavareei wrote:

Thanks MC,

Unfortunately that didn't work. After I loaded version 13, I booted to an untouched backup of my OS from when it worked, and still it has the same problem. I was using VLC an iTunes to test, since it loads faster than Pro tools. The audio starts fine, then after about 10 seconds, it lags and stutters, getting worse and worse.

I have tried many different combinations of firmware and driver with no luck. Is there no way to wipe out all trace of RME software and start from scratch?

I even swapped PCIe slots to the same result.

It seems to run OK in Windows, but I need to run more tests. Regardless, the Mac is my workstation that has many sessions with Mac only virtual instruments I need to get back to soon.

Please let me know if you have any other ideas.

Cheers,

AZ

In regards to Windows (Mac has surely something similar):

On your next fresh installation get a professional backup solution, then you can restore from backup at any time.
-> Macrium Reflect

For my system (SSD with 522GB filled) it takes only 10min for a full restore, because Macrium Reflects "rapid delta restore" mechanism writes only those blocks back to SSD which needs to be changed. This also also has the advantage to reduce the "wear" on the SSD.

Another solution is to set restore points in Windows. I personally trust backup/restore more.

BR
Ramses
X10SRi-F, Win7 Prof, Cubase 9.5, UFX+, Octamic XTC, ADI-2 Pro FS BE/DAC, RayDAT, ARC USB

22

Re: Pro Tools halts with RME RayDAT on any buffer size other than 1024

So as expected we are back to my post number 12. Nothing I can do from remote, though.

Regards
Matthias Carstens
RME