Topic: MIDI in + Enable MIDI Control prevents Windows 10 standby

I'm using Babyface and recently I started using the MIDI Control to control TotalMix and noticed that it prevents Windows 10 from entering standby.  It happens more specifically if I have both the "Enable MIDI Control" enabled inside TotalMix plus inside the MIDI Settings I have Babyface Midi Port 1 for MIDI In.  Running Command Prompt as admin, and typing "powercfg -requests" reveals that what's preventing the standby is SYSTEM: RME Babyface "An audio stream is currently in use."  I do not have anything attached to the MIDI port.  Is this a normal behavior?

2

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

No such problem reproducable. MIDI is not audio, that error message would only make sense with FX enabled . Turn off Echo and Reverb to check if it works then.

Are you on the current firmware and driver (1.113)?

Regards
Matthias Carstens
RME

3 (edited by ikonomov 2018-02-09 19:22:56)

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

Firmware 223, was using driver 1.099, now updated to 1.113.  Echo and Reverb both disabled, but I had EQ enabled for both AN 1/2 and Main (PH 3/4).  After updating the driver, and disabling EQ still the same problem.

Edit: I actually have 2 Babyface interfaces on two different computers.  I just tested it with the other one, and the same problem.

4

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

EQ doesn't matter. Disable the WDM devices for a test (in Settings dialog). This might be a WDM audio problem, not directly related to the BF.

Regards
Matthias Carstens
RME

5 (edited by ikonomov 2018-02-10 07:26:05)

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

I disabled all Playback and Recording devices in the sound settings of Win10.  No change.

6

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

I wrote: Disable the WDM devices for a test (in Settings dialog). Much quicker, easier and more relevant than your method.

Regards
Matthias Carstens
RME

7 (edited by ikonomov 2018-02-10 06:21:58)

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

I first looked anywhere in Settings and Preferences, and then in the PDF manual, and couldn't find where I can do that from TotalMix, so I assumed this is what you mean.  Where can I find Settings dialog?

8

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

In your notification area. Manual chapter 8. Configuring the Babyface -    8.1 Settings Dialog. The WDM option came in a later driver, set it to 0 and change the sample rate one time to remove all WDM devices.

Regards
Matthias Carstens
RME

9 (edited by ikonomov 2018-02-10 07:08:38)

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

Somehow I missed it, I was looking for a check box.  OK, I also restarted the computer.  It still won't enter standby mode.  So the only 2 things I am changing are:
Enable MIDI Control
MIDI In: Babyface Midi Port 1
If I disable either the MIDI Control or change the MIDI In to None the computer can enter standby.  I have set the turn off display and sleep both at 1 minute so I can test easily.

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

Any news if my problem is reproducible on your end?  If it only happens here then I am thinking of doing a clean windows install.  Thanks

11

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

I already wrote that it is not reproducable here. Nor did anyone else ever reported this behaviour.

Regards
Matthias Carstens
RME

12 (edited by ikonomov 2018-02-16 23:31:11)

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

I just reinstalled windows 10.  Clean install, from a newly created boot USB flash drive, with all settings reset to default before restarting (they are now synced), wiping all partitions and reinstalling.  After it installed I updated it, installed my drivers including RME Babyface and did the exact same test.  There is no change, the computer can enter sleep normally, and as soon as both of the settings in the following picture are chosen, the computer cannot sleep.  I have two computers, completely different configurations, with two different RME Babyface interfaces.  There is nothing running on either computer when I test.  I have reinstalled windows on one of the computers, but I can do the same on the other one, if needed to confirm.

http://i58.photobucket.com/albums/g246/ … tbfdvg.jpg

This is what Command Prompt shows:
http://i58.photobucket.com/albums/g246/ … klivcf.jpg

the computer with newly installed windows 10:
GIGABYTE GA-X99P-SLI
Intel i7-6800K
32GB RAM
EVGA GeForce GTX 1070

other computer also running windows 10:
MSI P6N SLI Platinum
Intel Core 2 Duo E6600
8GB RAM
MSI GeForce GTX 1030

The only things similar between the computers are the same Nvidia driver for the GPUs and Logitech driver for the mice.

Edit: There is nothing connected to the MIDI in connector, if that makes any difference.

Edit 2: Besides the different hardware, which might not be relevant, since I have two different configurations that show the exact same result, another variable is windows 10 versions and updates.  This could explain why the problem is not reproducible on your end and why nobody ever reported such behavior.  I noticed big differences between windows 10 major updates.  Is it possible that something in windows 10 is causing this problem?

13 (edited by ikonomov 2018-02-17 07:46:42)

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

I just wiped all partitions on the older computer (Intel Core 2 Duo) and installed Windows 7 to test if the same thing will happen there.  I had to wait couple of hours for all the updates to install, otherwise they would interfere with standby.  After no more updates were available, and I restarted, and made sure nothing was running the result is exactly the same.  Windows 7 turns off the monitor, but does not allow the computer to enter sleep mode.  As soon as I disable MIDI Control from TotalMix Windows 7 is able to enter sleep mode as normal.

http://i58.photobucket.com/albums/g246/ … zyyrzd.jpg

Edit: If somebody happens to read this topic who has RME interface and is experiencing the same issue (or not) please reply here.

14

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

I can confirm that 'powercfg -requests' gives the same message on my computers (An audio device...although this is clearly MIDI). Anyway, in both cases sleep still works...

Regards
Matthias Carstens
RME

15 (edited by pianopictures 2018-02-18 05:18:25)

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

Enable Midi Control - check
Settings > Remote Controller Select - 1, In Use - check
MIDI in - my midi keyboard
MIDI out - None
Disable MIDI in background - unchecked
Mackie - unchecked

Was able to set the PC to Sleep mode without any difficulties. Win 10 Pro, TMFX v. 1.43.

16 (edited by ikonomov 2018-02-18 06:50:46)

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

MC wrote:

I can confirm that 'powercfg -requests' gives the same message on my computers (An audio device...although this is clearly MIDI). Anyway, in both cases sleep still works...

Thank you for this explanation.  Any idea why sleep works on your computers, and not on mine?

I found a way to force windows to ignore Babyface driver https://en.wikipedia.org/wiki/Powercfg by typing powercfg -requestsoverride DRIVER "RME Babyface" SYSTEM, is this the best way to do it?

pianopictures, thank you for your reply.  If it won't be too much trouble, can you open command prompt as admin (hit start, type CMD, right click and run as admin) and type "powercfg -requests" without the " after your computer wakes from standby, and post if you see anything other than None.

17 (edited by pianopictures 2018-02-18 07:16:48)

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

Sure, here you are:

===========================================
Microsoft Windows [Version 10.0.16299.248]
(c) 2017 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>powercfg -requests
DISPLAY:
None.

SYSTEM:
[DRIVER] USB Audio Device (USB\VID_07CF&PID_6803&MI_00\7&1ff3ea79&0&0000)
An audio stream is currently in use.
[DRIVER] Legacy Kernel Caller

AWAYMODE:
None.

EXECUTION:
None.

PERFBOOST:
[DRIVER] Legacy Kernel Caller
Power Manager

ACTIVELOCKSCREEN:
None.


C:\WINDOWS\system32>
===========================================

What exactly do you mean be "standby" - sleep mode? So you are not able to put it to sleep mode manually or using the power saving settings so it can't automatically go into a sleep mode after a certain period of time?

18 (edited by ikonomov 2018-02-18 07:24:11)

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

I mean it can't go into power saving mode (standby/sleep)  by itself after whatever minutes are set in windows power options.  It is easy to test when you set both "Turn off display:" and "Put the computer to sleep:" at 1 minute in Control Panel\Hardware and Sound\Power Options\Change plan settings.

Edit:  On mine the monitor turns off, as it should, but the computer does not enter standby/sleep.

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

Now you better described it, so yes, I can reproduce it. Confirmed - not going to sleep mode.

20

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

I'll also check that later - never tried it that way.

Regards
Matthias Carstens
RME

21

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

Ok, I can reproduce it this way. Please be patient, we will need some time to check this in detail.

Regards
Matthias Carstens
RME

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

Thank you. I'm happy that I actually found something worth writing about here.

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

Hi Matthias, is there any progress on fixing the standby issue?  I just tried the newest version 1.114 driver and I'm still having the same problem.

Thanks

24

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

Unfortunately we were not able to find a quick fix for this behaviour. The MIDI port used blocks Standby via the system itself, and we don't have control over that. A possible workaround would be that we disable MIDI as soon as Standby shutdown queries arrive, but this needs more time and testing. If our disabling of the MIDI port happens after the OS queries its MIDI subsystem it would not work at all...or only on some machines, timing dependent...

Regards
Matthias Carstens
RME

Re: MIDI in + Enable MIDI Control prevents Windows 10 standby

Thank you for the reply.  I guess the expected behavior is that when people use a MIDI controller there is a program that's opened and then closed, not running in the background all the time like TotalMix.  I imagine that if somebody is using a large MIDI console to control TotalMix in a studio, the last thing they'll want is for the system to enter standby by itself.

In case anybody runs into this problem, I have found a workaround using powercfg utility https://en.wikipedia.org/wiki/Powercfg that I'm using which forces standby to ignore a system interrupt.

run Command Prompt as admin
- click start, type cmd, right click Command Prompt and then "run as administrator"

to check what interrupts standby:
powercfg -requests

to display list of ignored PROCESS, SERVICE, DRIVER by standby:
powercfg -requestsoverride

to add a driver ignored by standby:
powercfg -requestsoverride DRIVER "RME Babyface" SYSTEM

to remove:
powercfg -requestsoverride DRIVER "RME Babyface"

The driver name needs to be enclosed in quotation marks "".