1 (edited by pschelbert 2018-05-08 22:52:08)

Topic: Driver 1.114 blocks ASIO in Soundforge Pro11


after installing Driver 1.114 (Totalmix1.5) when I start Soundforge pro11 I get the error message:

"no analog1/2 available or in use by another application"

I rolled back to (13.7.2017) and everything is fine again with ASIO and Soundforge Pro11

What may block the ASIO access of Soundforge? I there something in Windows I should change?

Operating System: Win7 Pro, Service Pack1


2 (edited by pschelbert 2018-05-21 22:05:54)

Re: Driver 1.114 blocks ASIO in Soundforge Pro11

it may have to do with this mentioned in README to Totalmix1.5, Driver:1.114/V1.113.
May be this change caused the problem with SoundforgePro11.

V 1.113 (01/10/2018)

- Using more than one interface, the order of the ASIO channels can now be defined in the Settings dialog, tab About, with two different sorting methods. This feature brings them into the desired order, and also prevents random changes, for example after reboot.

- Change in the Installer to prevent ASIO rights problems with non-admin accounts

I verfied it the Totalmix1.5 and or Driver 1.114 reinstale the issue appears. Deinstalled the issue disapperared.

In the "Fireface USB setting", I see the menu to sort, however I get a strange error message.

Somehow the ASIO presentanion of the Fireface-driver to soundforge changed I guess.
Any idea how to do a workaround?



Re: Driver 1.114 blocks ASIO in Soundforge Pro11

No, it has to do with some changes in the supported formats that seem to have screwed up WDM compatibility. We are working on this right now.

Matthias Carstens

Re: Driver 1.114 blocks ASIO in Soundforge Pro11


strange as in Soundforg Pro11 I used the ASIO Drivers only.

I actually did not look what happened with WDM since I use the WDM only if not else possible.

Great. Just please state in the release notes of the driver what is supposed to be fixed.


5 (edited by pschelbert 2018-06-21 21:29:52)

Re: Driver 1.114 blocks ASIO in Soundforge Pro11

Problem gelöst.
Soundforge Pro11, Vinylstudio V9.06 (32Bit Treiber) läuft mit ASIO-Treibern.

War ein Microsoft Problem: Win7Pro hat das Problem erzeugt.
Lösung: update gemacht. Wobei letztes Update vor ca. 3 Monaten erfolgt war.

Treiber von UFX und UFX II, 32Bit und 64Bit waren im richtigen Verzeichnis. War alles okay mit RME Treibern und Installation der Treiber.

Problem solved.
Soundforge Pro11, Vinylstudio V9.06 (32Bit Treiber) works now with ASIO-Driver.
Was a Microsoft problem: Win7Pro has caused the problem.
Solution: update made. The last update was done about 3 months ago.

Drivers of UFX and UFX II, 32Bit and 64Bit were in the right directory. Everything was OK with RME drivers and driver installation.

Re: Driver 1.114 blocks ASIO in Soundforge Pro11

here more details:

The problem was with the emulation of 32Bit drivers in Win7Pro 64Bit.

The Bugfix of Microsoft does not mention anything about drivers and 32Bit.
However after installing this KB4284826:

June 12, 2018—KB4284826 (Monthly Rollup)
Applies to: Windows 7 Service Pack 1Windows Server 2008 R2 Service Pack 1

about a 200MB package! it worked.

Probably much more drivers were affected then only Soundforge Pro11 and Vinylstudio V9.06, namely any other 32Bit driver...

The 64Bit drivers worked always.


Re: Driver 1.114 blocks ASIO in Soundforge Pro11

Thanks for the additional information.

Matthias Carstens