Topic: DigiCheck - Latency - Buffer - Cubase

I am running Win 7 Pro SP 1 64 Bit, Core i7 2600K, 16GB Ram.
Cubase 8 Pro (8.0.2), I have two RME cards installed. HDSP 9652 and HDSP 9632, driver 4.1 DigiCheck 5.8
I tend to use Asio Guard in high and leave my buffer at 1024 or 2048 when mixing. Both my cards are synced off ADAT input from the same device. Apogee AD16X.

When I turn my system on I have to go in to the Hammerfall DSP settings and change the buffer setting and change it back again. If I don't do this I get no audio playback within Cubase, or on the occasion I do get audio without doing this it would be crackling badly.
I have recently started using the DigiCheck Totalyser on my iPad configured as a third display (although this issue is still present with out the iPad attached)
When I load in to a project when I have DigiCheck running all of my latency settings for external hardware are incorrect, anything using an external insert will be playing back out of sync. If I click the automatic compensation calculation button within the external plugin window it will normally then display 100ms (the maximum) delay compensation and the elements will become slightly less out of sync, still out of sync. If I go in to the DSP settings again and click to a different buffer, close the DSP window, reopen it and select a different buffer again, go back in to cubase and recalculate the delay compensation sometimes it fixes it, sometimes it does not. Normally after a few more attempts everything comes back in time however sometimes all audio playback stops and I have to restart either cubase or the whole system. I have to repeat this process every time I go in to a new project. All of my projects run in 24/44.1
I have tried  stopping audio processing in DigiCheck after opening it, before loading a new project and when switching projects but the outcome is always unpredictable. Also once I have the audio working properly I am getting different delay compensation times showing up when DigiCheck is running compared to when I load a project without having launched DigiCheck with the same buffer size set.
Any advice on this would be great as I really like having the Scope and Meter up while I am mixing.


Re: DigiCheck - Latency - Buffer - Cubase

Maybe just disable "Set sample rate for ASIO inputs" in DIGICheck's Input Device Setup? Don't know if this will help ...