Topic: Octamic ADAT stopped working for unknown reason.

Hello,

One beautiful day Octamic ADAT stopped working for unknown reason. When the device is turning on, ADAT blinks for a second and then stops working. Because the device is quite old and there is no warranty to it, I opened it up and inside everything looks fine, no visible damage. I know there were some problems with voltage regulators on these devices, but this unit haven't suffered this problem. Anyway, ADAT is not working. I suspect a small chip in digital board, but that's totally unsure. If you had similar problem or maybe know where a sollution could be found, please help me.

I made some video about the problem. https://youtu.be/xMp-nIcgYb4

Thank you very much.


Best regards,

Vytenis Gadliauskas

2 (edited by portoparasas 2017-06-15 00:21:43)

Re: Octamic ADAT stopped working for unknown reason.

Update:

It looks like everything is working, but Spartan chip is not providing voltage to ADAT (around 1.2v, (I/O (CS) P31, I/O (WRITE) P30). I changed small memory chip from another Octamic, but ADAT's are still not working. Memory chip from this board is working fine in another unit. After debugging with Spartan documentation, when Spartain is booting, last events should be "FPGA Drives DONE High, Activates I/Os, Releases GSR net". It seems that chip gets booted (pin DONE gets HIGH, INIT is HIGH). LED's are working at the front and takes signal level measurements. What could be the case with ADAT's?

RME technicians, please reply.

Thank you.

3

Re: Octamic ADAT stopped working for unknown reason.

Never heard of such a problem. But you leave lots of questions unanswered:

- Why are the DIP switches set to something that doesn't make sense? For testing they should all be in the upper position.

- Is AES I/O still working?

- Is analog working completely?

I would advise to send in the unit, or maybe just the digital expansion board for check and possible repair. Before repair is done you will get an estimate of the costs.

Regards
Matthias Carstens
RME

4 (edited by portoparasas 2017-06-15 23:45:39)

Re: Octamic ADAT stopped working for unknown reason.

Thank you for reply.

1. I changed all the dip switch positions, no effect on that.

2. Good point, I will check AES I/O tomorrow.

3. Analog is working completely fine.

I took a risk and changed Octamic digital board from my other Octamic unit. Replacement board is working fine in this unit, so the problem is with digital board only.

5 (edited by portoparasas 2017-06-16 00:33:43)

Re: Octamic ADAT stopped working for unknown reason.

Update: AES is not working in damaged digital board. So, the board is fried? Octamic is not working if there is no digital board inside (level meters, etc.), so some components of digital board are working fine. Could it be that only Spartan chip got damaged in some way? If so, replacing/re-soldering it should solve the problem? ROM memory chip is outside, so no programming needed?