Topic: Enable MMCSS for ASIO/Cubase 10 pro/Win 10 64 bit

Hi,

Should this setting be on or off for a setup like mine, i.e. Cubase 10 pro, Win 10 64 bit, HDSP9632? What difference will it make?

I have always had it off.

Best,

Magnus

Re: Enable MMCSS for ASIO/Cubase 10 pro/Win 10 64 bit

Magnus wrote:

Hi,

Should this setting be on or off for a setup like mine, i.e. Cubase 10 pro, Win 10 64 bit, HDSP9632? What difference will it make?

I have always had it off.

Best,

Magnus

I'd like to know a bit more about this topic also.

Similar setup here, Windows 10 x64, Cubase 10 Pro, HDSPe AIO, i7 5930k, 32GB RAM etc.

My Cubase 'Orchestra' wink  http://www.soundclick.com/members/default.cfm?member=kitara

Re: Enable MMCSS for ASIO/Cubase 10 pro/Win 10 64 bit

Noone?

/Magnus

Re: Enable MMCSS for ASIO/Cubase 10 pro/Win 10 64 bit

I guess I should test it yourself with a heavy loaded project and small buffer size.

Re: Enable MMCSS for ASIO/Cubase 10 pro/Win 10 64 bit

Dandruff wrote:

I guess I should test it yourself with a heavy loaded project and small buffer size.

Of course. I had hoped, however, for a reply from RME. They are usually very helpful in matters like this here on the forum.

/Magnus

Re: Enable MMCSS for ASIO/Cubase 10 pro/Win 10 64 bit

There is no simple right or wrong, else the option would not be needed....


Regards
Daniel Fuchs
RME

Re: Enable MMCSS for ASIO/Cubase 10 pro/Win 10 64 bit

Hi Daniel,

Ok, so this feature is no real biggie, then? What exactly does it do, and what impact would it have on a Win 10 system running Cubase 10?

Thanks for replying, btw.

Best,

Magnus

Re: Enable MMCSS for ASIO/Cubase 10 pro/Win 10 64 bit

In short, it sets the priority for the asio driver higher. This can have good and bad results. Plus some daws set this themselves some don't. Some need it some don't. It can make a difference but you will have to try. Just as best buffer size, hyper threading, which usb ports etc etc.

Vincent, Amsterdam
https://soundcloud.com/thesecretworld
HDSP9652+ADI-8AE  2X HDSP9632
Cubase pro10

Re: Enable MMCSS for ASIO/Cubase 10 pro/Win 10 64 bit

OK, great. I will try the setting and see if it makes any difference.

A big thank you to all who participated in this thread.

/Magnus

10 (edited by Timur Born 2018-12-12 17:38:49)

Re: Enable MMCSS for ASIO/Cubase 10 pro/Win 10 64 bit

Well, it's complicated, especially with Cubase. MMCSS was introduced with Windows Vista, alongside the introduction of the DesktopWindowsManager (DWM).

In the past all DAW software used non-realtime priority 15 for their audio, midi and the main ASIO (RME driver) thread. Then DWM came along and used the very same priority to display desktop content (like windows), which caused conflicts. MMCSS is a workaround to allow audio/midi threads to use realtime priorities above 15 (usually 24-26 out of 31) without threatening to stall the whole system.

Most DAW software needed years to implement MMCSS, if at all. Most software handles MMCSS on its own, but then Steinberg revised the ASIO specs making it mandatory for ASIO drivers to implement MMCSS on their own. This causes all kind of possible issues:

- The RME ASIO driver may use a different priority than the DAW software uses for its other multi-core MMCSS threads. Allowing to turn MMCSS off in the driver and thus allow the DAW software to control its priority is the way to go then.

- The DAW software may not use MMCSS at all and thus get into conflict juggling its lower priority multi-core threads versus the main ASIO driver thread. Disabling MMCSS in the RME driver again is the way to go then.

On the other hand some DAW software without MMCSS support still benefits from the RME driver's MMCSS option being enabled. Samplitude versions before the latest X4 are an example of this.

- The DAW software may expect the driver to set its own MMCSS priority while giving MMCSS priorities to its own multi-core threads only.

This is what I would expect Cubase to do, but when I just checked v9.5 it acts differently than expected. Even worse, changing sample size in the RME driver may reset priorities according to the RME driver's own MMCSS setting. I will get me a v10 license and test this further. Until then I recommend to enable MMCSS in the RME driver or to not switch buffer sizes while Cubase is running.

Again, it's a bit of a mess and having MMCSS available as an *option* in the driver is the best possible solution.

Re: Enable MMCSS for ASIO/Cubase 10 pro/Win 10 64 bit

Thanks everyone.

So, as it often is the case with these computer/DAW questions, it all depends... wink

Cheers,

Mauri.

My Cubase 'Orchestra' wink  http://www.soundclick.com/members/default.cfm?member=kitara

Re: Enable MMCSS for ASIO/Cubase 10 pro/Win 10 64 bit

Timur Born, thanks for your very detailed report, and thanks for looking into this at such depth. I am eagerly waiting for you to come back with results for Cubase 10.

/Magnus