Topic: HDSP 9632 not appearing in audio devices

Hi,

I have a strange issue whereby my HDSP 9632 has suddenly stopped working or appearing under audio devices, Windows 10 Pro. It is not appearing under Windows Sound settings as a device and it is not appearing in Windows Device Manager either (see screenshots).

My drivers are still installed and TotalMix FX and Hammerfall DSP settings are still appearing in my Windows taskbar (see screenshot), however, they do not open when I click on them. I have tried installing the latest drivers multiple times. I have made sure my PCI lane is working by inserting a USB 3 extension card and that is working fine.

See screenshots:
http://i67.tinypic.com/ogaukx.jpg
http://i64.tinypic.com/9qzc46.jpg
http://i67.tinypic.com/122cfbl.jpg


Any help greatly appreciated

regards
Aaron

Re: HDSP 9632 not appearing in audio devices

I have had this and it was dirty contacts. I had to remove the card from the system and clean the contacts with an eraser. Just doing it with a cloth didn't help. Of course i thought it was drivers etc before I tried this as a last resort.

Vincent, Amsterdam
https://soundcloud.com/thesecretworld
HDSP9652 ADI-8AE HDSP9632
Cubase pro 9

Re: HDSP 9632 not appearing in audio devices

Thanks but that didn't work. Now Windows doesn't seemt o want to boot unless I remove the card from the PCI slot?. Could it be malfunctioning?

Re: HDSP 9632 not appearing in audio devices

Try inserting it a few times or in a different slot! Same symptoms here. Took some real cleaning and inserting. Has been working for a year now again. Also try another computer maybe. But of course it can be malfunctioning too. The mobo can be malfunctioning too of course!

Vincent, Amsterdam
https://soundcloud.com/thesecretworld
HDSP9652 ADI-8AE HDSP9632
Cubase pro 9