1 (edited by EvilDragon 2017-05-08 09:53:10)

Topic: W10 Startup: TMFX doesn't start

Hello!

I have UFX+ connected to my W10 PC via Thunderbolt. Lately I've noticed that when booting up the system, RME DSP settings load up properly (I see the icon in the tray), but TMFX doesn't load up (I don't see the icon in the tray, I first need to manually open the program, which I have pinned to taskbar, then click again to open the TMFX window). Both are set up as startup items properly. It's a bit annoying needing to click two times to open TMFX...

Additional info: I have two monitors, and TMFX is located on the secondary one.


I didn't try to completely reinstall RME drivers, maybe I should?

A very happy RME UFX+ & ARC owner

2

Re: W10 Startup: TMFX doesn't start

Are you sure the app is not just hidden behind the chevron? Seeing your other problem makes me wonder which version of TM FX you start via your taskbar link...

Regards
Matthias Carstens
RME

3 (edited by EvilDragon 2017-05-08 12:23:16)

Re: W10 Startup: TMFX doesn't start

It's the latest version of TMFX, I definitely replaced the EXE files (if I go to Properties->Details of the EXE file, it says 0.1.4.2 for version).

Program is definitely not hidden in any way - it simply isn't running when booting the system up. It also happens even if "Always on top" is enabled. So I first need to run it manually from the taskbar, then I see the icon in the tray, and then click again to open the window. hmm


Are there any console commands I could use to remedy this situation?

A very happy RME UFX+ & ARC owner

4

Re: W10 Startup: TMFX doesn't start

No, but you could check the autorun of your Windows installation, for example via Start in Task Manager. TotalMix FX should be in there.

Regards
Matthias Carstens
RME

5 (edited by EvilDragon 2017-05-08 13:46:09)

Re: W10 Startup: TMFX doesn't start

It's there and in registry as well. No dice.

http://imgur.com/jtQhTR0.png

A very happy RME UFX+ & ARC owner

Re: W10 Startup: TMFX doesn't start

Any more ideas? This is very annoying, to say the least.

A very happy RME UFX+ & ARC owner

Re: W10 Startup: TMFX doesn't start

This is still a problem over here. The issue is made worse by making my ARC useless until I manually start TMFX, since it doesn't seem to start with the OS.

What's happening here?

A very happy RME UFX+ & ARC owner

Re: W10 Startup: TMFX doesn't start

Does TMFX never start when you re-start Windows or does it work sometimes and sometimes not?

I remember an issue back in Windows 7, where not all tray programs got loaded properly all the time when starting the operating system. The workaround was to set up a password for your account to give Windows a bit more time to load everything in the background. I haven't come across this problem in Win10 yet, but you never know...

Re: W10 Startup: TMFX doesn't start

It never starts, even though, as you can see above, it IS listed in Startup! I always have to run it manually - I have TMFX pinned to taskbar, so I need to click it TWICE to actually see the TMFX interface (once to load it, second time to open the interface)...

I already have a password for my account that I have to type before going to the desktop.

A very happy RME UFX+ & ARC owner

10 (edited by EvilDragon 2017-06-08 08:32:58)

Re: W10 Startup: TMFX doesn't start

OK, I think I have managed to find the solution to this issue!

TMFX was set to "Run as administrator". Looks like Windows doesn't allow running any programs as admin for startup.

Things are working as expected now!

A very happy RME UFX+ & ARC owner

Re: W10 Startup: TMFX doesn't start

EvilDragon wrote:

OK, I think I have managed to find the solution to this issue!

TMFX was set to "Run as administrator". Looks like Windows doesn't allow running any programs as admin for startup.

Things are working as expected now!

Great tip!  Was having the exact same problem.  This solved it.  Thanks!