1 (edited by stanley 2019-05-17 11:17:36)

Topic: [solved] Playhead not moving with ASIO (HDSPe AIO, Win10 64bit)

Sound works, but I haven't managed to get sound out from most DAW's using Hammerfall DSP ASIO.

I have tried with:

  • Acid Pro 7, 8, 9

  • Mixcraft 8

  • Reaper 5.97

  • Mixbus 32C v4

  • Samplitude Pro X2 Silver

The playhead simply won't budge, and TotalMix FX doesn't detect any activity on the DAW's output channels. It's almost as if the device was occupied by some other process, but AFAIK just based on what I've done, it should be grabbed by the DAW if anything.

I've tried different configurations with sample rates, buffer sizes, enabled WDM devices, default devices and exclusive control in Windows' sound control panel, and so on.

I had most "success" in Samplitude when I somehow managed to get sound out playing on MIDI keyboard, but then it crashed and I don't remember what I had done to get to that point, nor if the playhead worked. I'm pretty sure I had fiddled with routing in Samplitude prior to getting the sound out.

I imagine there must be some logic to how Hammerfall DSP and the DAW should be setup, but I haven't been able to get it to work. Probably worth mentioning that I did get ASIO4ALL v2 to work with Acid Pro, and Windows' audio system also does work.

What makes it seem so futile is that there are at least three different places where you can change the settings:

  • Hammerfall DSP Settings

  • TotalMix FX

  • Windows Sound control panel

If anyone could help by either explaining the logic in clear terms (assume I know next to nothing), or give a simple working configuration, I'd be very grateful.

Some info, FWIW:

  • OS: Windows 10, 64bit

  • CPU: Dual Xeon @ 2.7-3.3GHz (8-core, hyperthreading on)

  • RAM: 96GB DDR3 @ 1333MHz

  • Latest driver (v4.28) and firmware (rev. 14)

Also: At first I was experiencing crashes after installing the card, and the entire Windows desktop would freeze for several seconds very frequently, during which time not even mouse input worked. The crashes went away after I tweaked some BIOS settings, most of which I've now restored because something seems to be giving me other performance issues. I think I now have C6 state turned off, possibly without C-state limit.

Re: [solved] Playhead not moving with ASIO (HDSPe AIO, Win10 64bit)

1st of all, get rid of ASIO4ALL and use the RME ASIO driver only.

This won't have to deal with your problem, but
if you want to disable power saving and want to make your machine reacting more agile, then disabe C-states by either disabling or setting them to C0/C1. Also disable C1E as well as P-/T-States if your BIOS still have these settings.

WDM driver you only need for the operating system and applications which do not support ASIO. You usually only need to create WDM devices for the 2 analog outputs where your speakers are connected to. And in the separate tab speakers you select these ports as well because this creates the driver/entry in the Windows Sound System which the main audio device is for Windows, Output of system sounds (which you should disable) and for non-ASIO aware applications like ie Webbrowser when watching youtube.

See my blog article how to setup TMFX step by step : http://www.tonstudio-forum.de/blog/inde … rnal-equi/

These RME videos are also much helpful and also read the handbook: http://www.tonstudio-forum.de/blog/inde … al-Videos/

X10SRi-F, E5-1650v4, Win10 Pro 1909, Cubase, UFX+, XTC, ADI-2 Pro FS R BE, RayDAT, ARC USB

Re: [solved] Playhead not moving with ASIO (HDSPe AIO, Win10 64bit)

Thanks for the info and the excellent tutorial, I wish I'd found it when I was trying to get just any sound out of the card.

However, I still don't know why my playhead isn't moving.

I tried disabling all WDM devices from the Hammerfall DSP settings and cleared the routing matrix.

Is there any way to get a deeper look at what's happening behind the curtains, like list the current ASIO clients and settings, etc.?


Re: [solved] Playhead not moving with ASIO (HDSPe AIO, Win10 64bit)

Playback not starting means no hardware interrupts. Try a different PCIe slot.

Matthias Carstens

Re: [solved] Playhead not moving with ASIO (HDSPe AIO, Win10 64bit)

MC wrote:

Playback not starting means no hardware interrupts. Try a different PCIe slot.

That did it! Thank you.

First I tried changing some BIOS settings that had to do with CPU or PCIe, and although I did get a noticeably faster desktop it didn't affect the card.

Then I moved the card to another slot, and the playhead moves now, and sound comes out without hassle. I'm experiencing pops and cracks occasionally but there's a handful of tweaks left to try in remedying those.

I've attached the schematics just in case somebody wants to guess what might have caused the problem.

My original reasoning was that I want HDSPe AIO on a separate link from the GPU and given the opportunity I initially thought it was a good idea to put it on lanes managed by a different CPU, so since the GPU was in slot 4 (CPU2) and occupied the space of slots 2 and 3 (CPU1), I installed AIO in slot 1 (CPU1), i.e. the lowest slot.

After installing I realized that the numbering in the schema indicated that the link of slot 1 was shared with the NIC's (LAN, 10Gbit!), so I wanted to move AIO to a different slot but since the GPU was blocking slots 2 and 3 and I didn't want to get AIO closer to the GPU, I left it there.

Finally, I moved the card  from slot 1 to 7, i.e. from bottom to top. Although (IIUC) it is sharing the link with slot 6, the other slot isn't populated.

mobo schema & layout