Topic: RME MadiFace ExpressCard34 and Sonnet Echo Pro ExpressCard34


Short version -

Per Sonnet support, the Sonnet Echo Pro ExpressCard34 may not work with the RME Madiface Expresscard34 despite past and current situations where it works fine for others.

Long version -

Around 1.5 years ago we purchased a Sonnet Echo Pro ExpressCard34 to prolong the life of our single Madiface Expresscard34 because we were retiring the ExpressCard computers, and the MadiFace EC34 had been a reliable product with the usual great RME driver support.  I initially tested it with a computer, it worked ok through a few tests, then it went on the shelf.

Approximately 10 months after purchase we used the MF and EE34 for tracking some television shows.  Depending on the day the MadiFace took between 1 minute and 5 minutes to initialize.  The MadiFace worked fine in an ExpressCard34 equipped computer.  I tried it on three different Mac TB2 computers and different ports, two different OSs, with different cables and could never establish a timing pattern.  Symptoms -

- The LED on the MF flashes on and off at a slightly irregular rate, approximately once per 5 seconds, indicating unsuccessful boot process.

- The MadiFace does not initialize nor does RME Settings.

- The Sonnet EE34 is immediately recognized in the System Information device tree.

- The Console log indicates no audio streams starting (which it does on initialization).  There are no log errors. 

- If I wait long enough, between 1 and 5 minutes, the MF will initialize, the logs indicate audio streams starting, RME Settings will launch with the MF functioning properly, and there are no log errors in starting.

- Tested with an external TB2 dock as well.

- Tested with items attached pre and post boot, same varying results.

This show ran for around 7 weeks so my workaround to avoid confusing the operator was to power up the computer early so it would launch before he arrived, with the intention of researching the issue later.  Subterfuge and misdirection.

After the show run the EE34 was put back in storage.  Approximately 1.3 years after purchase I started the research again.  Initially I suspected a power issue so I took the unit apart to determine any overheating issues.  Despite the warranty running out, after seeing my notes Sonnet was willing to send me another unit.  I've now tried three different units, all of them new, and all exhibit the same behavior.  I asked about the different hardware versions of the unit and was told that wouldn't matter in this case.

Sonnet's engineers did not have a MF EC to check with, I offered to send them mine for testing but they did not think that was necessary.  After the third unit exhibited the same issues I received an engineering response to the problem -

Hello Hugh,

We have been running through this with our engineering team, and we have come up with a few reasons as to why this may not be working for you.

The most likely problem is the PCI interface; the original version with the mechanical lock was forced to Gen1 speed only (250 Mbits/sec); then there was a version with a lock that could run at Gen2 speed (500 Mbits/sec); and then there was the non-lock version  that always ran at Gen2 speeds. There have been a handful of cards that didn't link at Gen2 in the E./34 adapter (One of the Marvell SATA controllers, among others). My guess is that as the card warms up, it finally is able to link ; that is why Hugh sees it link after 1-5 minutes. The symptoms he describes are the classic issues of a PCIe link not coming up; no errors are reported, the Echo Express shows up, everyone else thinks that nothing is connected.

The System Information Report will show the link speed that the adapter connects at - it will look like a Firewire device. Most of those devices were Gen2.

Note that even though the Echo Express is capable of Gen 2, and the chip is capable of Gen 2, it still may link at Gen 1; that is a fall back mechanism designed into the PCI Express protocol. The capability of the Echo Express to run Gen 2 can be seen in the IORegistry, but it is rather obscure.
If you would like to check that out, we’ll just need system reports.

Odds are good that the MADIface is probably a Gen 2 card. With the Gen 1 Echo Express, everything runs at the slower Gen 1 speed, all is well
With Gen2 Echo Express, it apparently fails to link, and fails to properly fall back to Gen 1. Hence it doesn’t work until it warms up.
It is unknown whether it ends up in Gen1 or Gen2.
The Gen2 interface of the Echo Express is probably the weak point in all of this.

For a potential solution: The Thunderbolt 3 SF3 SxS adapter shown here is a completely different electrical interface, and while we can’t really say whether it will work with the MADIface or not (as we do not have one to test), our guess is that it would.

Let us know how you would like to proceed, and we can go from there.

Thank you for your patience with this.

I appreciate Sonnet's work in attempting to solve this, they were cooperative and willing to work with me after the warranty expired.  I understand the Gen1/2 versions and falling back to Gen1.  I don't know what "warming up" has to do with negotiating a link but after trying three different units there is certainly an issue.  Unfortunately the potential solution is purchasing another product at more than double the price and much larger and heavier.  The MF EC34 is a good product and still works great in the single ExpressCard34 computer we still have, and RME's driver support is unequalled, but I think for us it's a loss.  Our accountants are not amused but that's expected.