Topic: Multiface II at xubuntu, how to set as default card?

Hi all, I used to use my Multiface II (PCI) on Fedora 8 without problems,
but now since I moved to xubuntu 12.04 I have a problem of selecting the card as a fallback / default,
thus any audio played is never routed to the RME card.

After reboot I run hdsploader + hdspmixer, this works.
Then in alsamixer I can see the card but all controls are set to 0, I can't change them.
I read that xubuntu is using pavucontrol instead but this program does not show my RME card.

However, audacity can see the card and happily plays sounds through it, so I know
the hardware and drivers are working OK.

Pity now that audacity does not have a "set default card" option :-/

Any hints?

Thanks in advance,

/Per Nordqvist

Re: Multiface II at xubuntu, how to set as default card?

I'll answer my own question, partly:

I'm mostly using FMOD to play sounds, and in this API I found the command "setDriver(int cardnr)"
which directs output to a specific card, not only the default.

Still I'd be interested in a generic solution if there is one.

Re: Multiface II at xubuntu, how to set as default card?

I finally came up with a recipe for this, but it could probably be trimmed down.
Let me know if you try it, I'd be happy for any feedback.

Making the Hammerfall card default in xubuntu

xubuntu 12.04
RME Hammerfall Multiface II (PCI variant, not PCIe)

Assuming you have installed firmware, run hdsploader + hdspmixer as

aplay -l now should recognize the card as DSP. In my case I see

1:DSP Hammerfall

so to play a sound I can use
aplay -D plughw:1,0 test.wav
(plughw seems necessary, only hw will not work)

Now, to make the DSP card default and sorted at location 0 I performed
these 9 steps.

1. Edit Xfconf settings: … in-xubuntu

2. Remove pulseaudio, use only alsa. … ntu-linux/

3. Remove package gstreamer0.10-plugins-good
(older distros call it gstreamer-pulse)

4. Create $HOME/.asoundrc as below, using 0 & 0 for card & device.
(Don't care about the cards real position at this point)

pcm.!default {
      type plug slave.pcm {
            type hw card 0 device 0

5. Now check again the cards position with aplay -l
For me the order now is

3:DSP Hammerfall

6. Restart alsa:
sudo alsa force-reload
(other distros use other commands, like /etc/init.d/alsasound restart)

7. (Weird) repeat step 5 + 6 and the DSP card position now toggles
between 0 & 3 with every alsa force-reload. So just reload alsa until
DSP position is 0 which now matches your .asoundrc.

8. Run hdspmixer to unmute the card, because every reload will mute it.

9. Done! Test by a simple 'aplay test.wav'

Final remark: if you want to try unload and reload the firmware by
rebooting, make sure you shut down your machine properly. Only
restarting will not work because the card will still have power from
the firewire cable.